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About This Guide

In this User’'s Manual, it is assumed that the user is familiar with the
Microsoft Windows operating environment. This includes an understanding on
how to:

1. Use a mouse or other pointing device to click, double click, drag and
select information

Scroll using scrollbars

Open and close program in Microsoft Windows

Type using a computer keyboard

a kWD

Navigate or selecting menus and submenus

It is also assumed that the user is familiar in microcontroller programming
either in C or assembly language. The user must have knowledge on
compiling/debugging source codes and is well aware of some electronic terms
and numbering system. Moreover, it is also assumed that the user is
knowledgeable on the standards and safety precautions in operating

electronics hardware and correct handling of microcontrollers.
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I. Overview

This user manual will guide you in using ALEXAN ATMEL Device Programmer

Software.

This software can program the ATMEL AT89C2051 and AT89C4051

microcontroller.

It has a comprehensive set of features that allows you to view, program,

erase and secure the data of an ATMEL microcontroller. Equipped with a

computer-interface, the computer-interface software allows you to:

1. Load or open hex files containing the code you want to program to the
device.

2. Read the hex code from the device and store it in the program buffer for
editing or saving.

3. View and edit the hex codes in the program buffer.

4. Save any changes made in the program buffer to a hex file for use with

other devices.

Check the device ID.

Erase all the data in the device.

Blank check the device.

Program the hex codes found in the program buffer to the device

© N o>

Verify the programmed hex code in the device
10.Protect the device from accidentally reprogramming by locking the device

so that the code cannot be read from it.

For more information about ATMEL microcontrollers, please visit ATMEL'’S

website at http://www.atmel.com to download datasheet and technical

notes.
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1. Installation

To install the ALEXAN ATMEL Programmer computer-interface, do the
following:
1. Insert the CD containing the ALEXAN ATMEL Programmer into the CD-
ROM.
Run the setup.exe file.
Follow the instructions given during setup.
After the installation is finished, click ok.
To run the ALEXAN ATMEL Programmer, go to:
Start 2> Programs > ALEXAN ATMEL Programmer

a kb WD

111. Getting Started

What You Need To Get Started

1. Personal Computer with CD-ROM and serial or USB port

2. ALEXAN ATMEL Programmer Software

3. ALEXAN ATMEL Programmer Module

4. RS232 Serial Cable Or a USB to COM/Serial cable.
Note: To create your own RS232 serial cable, connect PIN2 to PIN 2, PIN3
to PIN3 and PIN5 to PINS.

5. 12 to 16Vdc Power Adaptor

6. AT89C2051 or AT89C4051 ATMEL Microcontroller (or MCU)

7. Any debugger/compiler software where you can write your source code
and compile it to a hex file format

8. A Hex file
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1V. ALEXAN ATMEL Programmer Module

RS232 connection; Must be
connected to the computer
using serial cable.

DC Jack for 12 to
18Vdc 500mA Adaptor

Busy LED; Blinks during
programming.

Power
Indicator

This lever must be
lowered down during
programming to hold
the MCU in place.
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ZIF socket. Insert your MCU here. Pins 10 and 11 of MCU
(located at lower bottom) must be connected to the bottom-
most pins of the ZIF socket (pin 12 & 13).
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V. ALEXAN ATMEL Programmer Computer-
Interface Software

¥ Alexan ATMEL Programmer EJ|E|E\
File Edit Tools Settings About

C M € flaw g e
Buffer 1 1 Buffer 2 | BT beviee Infermation

Matne: ATEAC2051
* Compatible with MCS 51

AGDR O 2345é'!—E9ABCDEFDIZ3456789ABCDEFi‘ f";"‘(”g‘fmw
ooon 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 Reprograrmmmable Flash
0010 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . o« .« « W o e Mernory
0020 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . .+ .+ v v+ v v e e SEIEIEE I
IniiteErase Cycles
0030 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . . . . . . . . . . . . . .. 3 7o 61 Opersing Range
0040 00 00 00 00 00 00 00 00 - 00 00 00 00 0D 00 00 00 . . . . . . . . . . . . . . .. * Fully Siatic Operaton: 0
0050 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . . . . . . . . . . . . oo D i
* Two-level Program
D060 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . . . . . . . . . . . . . .. Mermory Lock
0070 00 00 00 00 00 00 00 0O - 00 00 D0 00 0D 00 00 00 . . . . . . . . . . . . . . .. * 128 x Bt Ineal RAM
D0BD 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 [irj::"’gmmma‘“'e”o
0090 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . . . . . . . . . . .« . . . . T B T s
00AD 00 00 00 00 00 00 00 0O - 00 00 D0 00 00 00 00 00 . . . . . . . . . . . .« . . . . * Six It Sources
DOBO 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 ez
UART Channgl
D0S0 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . . . o o« « 4o * Ditet LED Diive Outputs
00BO 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . . .« .« .+ o o 0 v e * On-chip Analog
OOED 00 00 00 00 00 00 00 00 - 00 00 40 00 00 00 00 40 (i Ay
* Low-pouvet ldle and
DOF0 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . . .+ o o« o W v st it A
0100 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 . . . .+ .+ + © + 0 v v * Brown-out Detection

0110 00 00 00 00 00 00 00 00 - 00 00 0 00 00 00 00 00 . . . . . . .« « . « . . .. - [FELTERE Rl

0l20 00 00 00 00 00 00 00 OO0 - 00 OO0 00 00 00 00 00 00 . . . . . . . o . . .
0130 00 00 00 00 00 00 00 OO0 - 00 OO0 00 00 Q0 00 00 00 . . . . . . . . . . . . . ...
0140 00 00 00 00 00 00 00 OO0 - 00 OO0 00 00 00 00 00 00 . . . . . . . . . . . . . ... ﬂ

[
Figure 5.1: Programmer Computer-Interface Software

Once the program has been successfully installed, you are ready to run the
program. After starting the programmer software, you will see the window as
shown in Figure 5.1. Menus and submenus, toolbar buttons and shortcut

keys are provided for ease of navigation.
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How To Program A Device

To program a device, do the following:

1.
2.

Connect the Programmer module to the serial port of your computer.

Plug the DC jack of the adaptor to the Programmer module then plug the
adaptor to the AC outlet to turn on the power.

Insert the AT89C2051 or AT89C4051 device to program in the ZIF socket

of the Programmer module.

4. Run the ALEXAN ATMEL PROGRAMMER software.

At startup of the software, it will automatically search for and connect to

the serial port the Programmer module is connected to.

Alternately, you may select the serial port to connect to by selecting the
Serial Port Setup (press F9). After selecting the appropriate COM port,
press OK. The programmer will then search for your Programmer module.
If a connection failure occurs, either you do not have a COM port available

or another application is using the COM port you selected.

. Choose AT89C2051 from the dropdown box (press F11l) to program

AT89C2051 MCU or AT89C4051) (press F12) to program AT89C4051
MCU. Make sure that the selected IC in the software matches that of the
IC you have inserted in the Programmer module. Information about the
device you choose is shown on the right side.

Open a hex file (*.hex). On the File menu, click Open File. Make sure
that your compiler generates a hex file from your source code since the
programmer will only allow a valid hex file format with a *.hex extension
to be opened. The hex code is shown on the current active buffer tab. A
maximum of 3 files may be opened.

To edit the programmer buffer, click the desired address and change the
value that you want by typing any hex values from 00 to FF.

To save the codes in the program buffer of the current tab to a hex file,

on the File menu, click Save File (press CTRL+S).

10.To program, on the Tools menu, click Program Device (press F5).
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A form is displayed as shown in Figure 6.1. It contains an auto program

function where you can still check and uncheck programming options

available. Go to Chapter 6 for the detailed description of each option.

Click Run to start programming.

¥ Program Device - ATMEL ATB9C2051

v

< < < <7

<

v

Select any options and cfick BUN:

ID Check

Erase Device
Blank Check
Program
Yerify
Lockbit 1

Lockbit 2

Check all Uncheck all

Alexan ATMEL 89CX051 Programmer v.2

Figure 6.1: Program Device Form
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V1l.Programming Options

ID Check
AT89C2051 and AT89C4051 is the only recognized MCU and each has
its unique ID. The 1D Check option will verify if you have inserted a
correct MCU to your Programmer module. Make sure that the device
you have selected in the Programmer software must match with the
one you are programming. In cases where the ID code of your MCU
has been damage, you can still program by unchecking this option.

Erase Device
The Erase Device option will erase the entire PEROM (Programmable
Erasable Read Only Memory) array of your MCU.

Blank Check
The Blank Check option will check if the entire PEROM array has been
erased.

Program
The Program option will write the hex codes in the software’s
programmer buffer into your microcontroller.

Verify
The Verify option will check if the microcontroller has the same hex
codes with that of the programmer buffer’'s hex codes.

Lockbit 1
The Lockbit 1 option will protect your MCU from reprogramming. The

microcontroller cannot be reprogrammed unless it is erased first.
Lockbit 2

The Lockbit 2 option will hide the data bytes of your microcontroller.
It is used for security purposes so that other users cannot copy what is
inside your MCU. Take note that Lockbit 2 requires that you select also

Lockbit 1.
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VII11.Other Features

Fill

To fill certain addresses of the buffer/s with a specific data, you can
use Fill rather than manipulating each data one by one. Just check
which buffer tabs you want the Fill to apply. On the Tools menu, click
Fill (press F3). The Fill form is shown in Figure 8.1.

E2Fill B=)E
Start Address: ’m Edi...

End Address: 07FF ol Vel Vel

Data to Fill: FF [ Tab3 [ All Tabs

oK

Figure 8.1: Fill Form

Read Device

If you want to know what is programmed in the MCU, you can read
and view the data bytes for each address - 00h to 7FFh for AT89C2051
and 0O0Oh to FFFh for AT89C4051). On the Tools menu, click Read

Device (press F4). A form is displayed as shown in Figure 8.2.

Select Run start reading. You can uncheck the ID Check box if the ID
code of your MCU is damage. Open the programmer buffer to view the

read data.
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£ Read Device - ATMEL AT89C2051

Select any options and click RUN:
v 1D Check

v Read Device

Check All Uncheck All

Figure 8.2: Read Device Form

Compare
The Compare option allows you to see the differences between the
data byte written in your MCU and the data bytes currently loaded in
the programmer buffer. On the Tools menu, click Compare (press
F6). The programmer will read the entire PEROM array of your MCU
and, then, compare it with the data on the programmer buffer. All

differences will be displayed in the grid as shown in Figure 8.3.

To save the differences, click Save to File. The file is saved in a text
file format (*.txt format) containing the difference between the device

data and programmer buffer data together with its address.
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Save To File
Addr | Buffer Data | <=> [ D

Figure 8.3: Compare Device Form

Unused Bytes
Default unused bytes set is 00. To change the unused bytes between
00 and FF, go to Settings menu, then, select Unused Bytes. Click 00
(press CTRL+F1) or FF (press CTRL+F2) for the desired unused bytes

to use.

Disassemble
The corresponding assembly code of the hex file on the current buffer
tab may be viewed by selecting Disassemble on the Tools Menu
(press F3). You can then save the disassembled file as a *.txt file. The
disassembled file is not guaranteed to run when you compile it on your

editor.
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1X. Troubleshooting

Invalid Hex File!

Read File Error E|

@ Invalid Hex File!

This occurs if the hex file you are attempting to load is not a valid hex

file.

Programmer Missing!

£ Program Device - ATMEL ATB9C2051

Select any options and click RUIN:  [————— START -—---
Programmer missing!
W ID Check  |777°- L
-
¥ Erase Device
v Blank Check
v Program
v Werify
?: Serial Port Setup
¥ Lockbit 1
Select Serial Port:
¥ Lockbit 2
i i
Check all Uncheck all
i o COM4 Close
ATMEL Programmer missing at COM4!

This occurs if: (1) Programmer module is turned off; (2) serial cable is
not connected and/or is damaged; or (3) other application is using the
same COM port. Configure your serial port so that during programming
it can be used only by the Programmer software and is located
between COM1 to COM4.
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ID Check Failed!

¥ Read Device - ATMEL ATB9C2051

Select any options and click BUN:  |————- START —-——-—

Detected at COM port 4

ID Check FAILED! 85C4051 Found.
_____ END —————

v Read Device

Check all Uncheck all

Check if the MCU you selected in the ATMEL Device Use option is the
same with the MCU that you have inserted in your programmer
module. Check for the correct insertion of the MCU. Check if the ZIF

socket knob has been locked.

Program Failed!

#7 Program Device - ATMEL ATB9C4051

Select any options and click RUN:  |[-———- START -----—
Detected at COM port 4
W ID Check ID Check 0OE!
Eraze 0OE!
- Elank Check OE!
Program FAILED!

- END -——--
v Erase Device

v Blank Check
¥ Program

v Verify

v Lockbit 1

v Lockbit 2

Check all Uncheck all

Check if the power is turned on. Make sure the MCU is inserted properly into the

ZIF socket. Reinsert MCU if necessary.

Alexan ATMEL 89CX051 Programmer v.2 Page 14 of 15



Ve, AHevan

Verify Failed!

#7 Program Device - ATMEL ATB9C2051

Select any oplions and click RUN: [ STADT ————m
Detected at COM port 4
¥ ID Check ID Check OK!

Erase OE!

Blank Check OE!
Program 0K!

: Verify FAILED!

Erase Device = |-———- END —-————

< T

<]

Blank Check

<]

Program

<l

Verify

<]

Lockbit 1
v Lockbit 2

Check All Uncheck all

Be sure that the ZIF lever is in lock position. Check if the power is
turned on. Check if the MCU is inserted properly. Make sure that the
serial cable is working properly. Reconnect MCU and program again.
Please note that if the MCU has reached its 1,000 erase/write cycles, it
can no longer be programmed. In some other cases, MCU had been
damage, and therefore it is not capable of reprogramming. Check the

ATMEL datasheets for the correct handling of your MCU.
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