Home - Search - Members
Full Version: project from cornell Accleration sensor
zedicus
Apr 13 2010, 8:51 AM
i am currently doin a project listed in the cornell final year project site, the project is a foot accleration sensor and the url is below

http://courses.cit.cornell.edu/ee476/FinalProjects/s2009/vlc6_ljs62/vlc6_ljs62/vlc6_ljs62/index.html

currently ive done exactly as instructed in the website but still i am gettin the following error when i try to receive data through matlab from the serial port


Warning: A timeout occurred before the Terminator was reached.
Warning: The input buffer was filled before the Terminator was reached.
Warning: The input buffer was filled before the Terminator was reached.
Warning: The input buffer was filled before the Terminator was reached.
Warning: The input buffer was filled before the Terminator was reached.
Warning: The input buffer was filled before the Terminator was reached.
Warning: The input buffer was filled before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.
Warning: A timeout occurred before the Terminator was reached.

??? Error using ==> serial.fgetl at 62
OBJ must be connected to the hardware with FOPEN.

Error in ==> accelerationGUI>startButton_Callback at 219
out = fgetl(handles.s); pause(.0001);

Error in ==> gui_mainfcn at 96
feval(varargin{:});

Error in ==> accelerationGUI at 42
gui_mainfcn(gui_State, varargin{:});

??? Error while evaluating uicontrol Callback

if any1 can shed some light where i have gone wrong would be very much appreciated
sorry to trouble u all.. i am also superbly stuck rite now.



Ajay Bhargav
Apr 13 2010, 10:11 AM
check on a terminal software if you're getting data frames correctly. looks like you are missing data during wireless transmission. i suggest you to try to check data on serial terminal and see if you are getting right amount of bytes with terminator.

communication part includes some handshaking too.. do check that in the project documentation.


zedicus
Apr 14 2010, 4:43 AM
meaning like serial port monitor?.. wil do tht.. there is handshake in this.. ill let u know the details of wht i see using tht ...

zedicus
Apr 17 2010, 5:57 AM
well.. got tht fixed.. tho now.. the wireless sometimes connect.. and sometimes dont.. meaning .. when i press to plot data.. the data is blank.. but once in a while when i press plot.. the data begins to plot~!.. i donno the cause of this.. cant imagine why..
Ajay Bhargav
Apr 19 2010, 6:34 PM
well this is only hardware issues.. maybe coz of loose connection, noise etc..
PC side has nothing to do with it.

On additional side for debugging you can tap data coming from XBEE receiver, so you can make out what data is being sent from xbee.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Rickey's World © 2003 - 2007