Discussion in "General help Guidance and Discussion" started by    daemotheo    Jan 20, 2010.
Wed Jan 20 2010, 03:59 AM
#1
we're currently doing our project and we are being bugged by our stepper motor... we had seached the net for necessary files, including datasheets and wiring diagrams, but none had helped us.... we're using a 5.1V 1A 200S/R Stepper motor with 6 wire leads......we connected it to a circuit driver, checked and rechecked every component for so many times, yet WE CANNOT MAKE IT TURN!!!!!

HELP US PLEASE.....anyone.
Wed Jan 20 2010, 05:45 AM
#2
have you identify leads?

1a ,1b, 2a,2b

Hope following link will helpful for you.

http://www.embeddedcraft.org/steppermotor.html

--
Gurpreet Singh
http://www.embeddedcraft.org/
Wed Jan 20 2010, 04:34 PM
#3
See if this helps you out:


 shyam like this.
Tags stepper motor wiringstepper motor connectionBLDC motor connection
Wed Jan 20 2010, 09:46 PM
#4
Read the stepper motor tutorial in the Tutorials forum.
If you are still stuck, post your circuit diagram.
Give as much information as possible, about what you have done
and what happened.
Thu Jan 21 2010, 01:42 AM
#5
to Gurpret312:
=>yes, we had identified the leads from the datasheet of the stepper motor.....
=>thanks for the link, it's not much of a help though cause we had the same info from various sites.

to DavesGarage and ExperimenterUK:
+thanks for the info..... but we're still stuck.... here is the schematic we used....with A -> A+ (white/green), B->A-(green), C->B-(red), and D->B+(white/red)....that's the last combination we used...we even tried moving three leads, keeping one lead on place, using different combinations but still, NOTHING HAPPENS....



Thu Jan 21 2010, 05:54 PM
#6
Full article
http://home.cogeco.ca/~rpaisley4/Unipolar.html

Start by removing the motor and replacing each coil with an LED
and resistor.
Then..
Does D1 flash at a sensible steady rate ?.
Do the four test LEDs turn on and off one at a time and in order ?.




Fri Jan 22 2010, 09:51 AM
#7
Sun Jan 24 2010, 06:43 AM
#8
a new idea just came in....i was told that - "maybe we are not generating enough current to run the motor" - AND HE'S RIGHT!...now, may i ask anybody who happens to have a current amplifier circuit?.... i had been searching the web but i cannot find anything that we need or maybe i am looking at the wrong place???? anyone??
Sun Jan 24 2010, 04:29 PM
#9


a new idea just came in....i was told that - "maybe we are not generating enough current to run the motor" - AND HE'S RIGHT!

daemotheo


How do you know he is right ?.

The output of a ULN2003 doubled up, should be enough to at least move your motor
although using four power transistors instead,may be better.

Is the five volt supply to the motor able to supply an amp ?.

Just in case the ULN2003 is burnt out.. replace it.. then add LEDs as I suggested.
See what happens.

Please stop using multi coloured text in your posts, some of it is hard to read.
Tue Jan 26 2010, 12:13 PM
#10
TO ExperimenterUK

How do you know he is right ?.
-we tested the current being supplied to the components....
The output of a ULN2003 doubled up, should be enough to at least move your motor
although using four power transistors instead,may be better.
-ok, we'll give it a try...but how are we going to connect it?....can you give me a schematic diagram? (or if you got a current amplifier circuit, it'll be much better ile)
Is the five volt supply to the motor able to supply an amp ?.
-NOPE....we just found out recently....(we're newbies.....)
Just in case the ULN2003 is burnt out.. replace it.. then add LEDs as I suggested.
See what happens.
-ok, we'll give it a try....
Please stop using multi coloured text in your posts, some of it is hard to read.
-ooppppsss......sorry.


one more thing, we connected LEDs to the part where there should be coil(motor), three of them flashed, two simultaneously while the other alternates, one was not blinking though the LED was in good condition, we suspects that the line/connection to the D coil, the one that didn't blink, which was connected to the 74194(specifically pin 13) was damaged....what do you think?

Get Social

Information

Powered by e107 Forum System

Conversation

Thu Nov 21 2019, 12:30 PM
raj2555
how to interface 8051 microcontroller with NRF24L01+ module
ExperimenterUK
Sat Oct 12 2019, 10:23 PM
Log in.. then post your code in the 8051 forum
Sat Oct 12 2019, 10:18 AM
Bhadra Sajikumar
i am doing a countdown timer with 8051 for my project, unfortunately our professor had to take a leave of absence before he could teach us most of it.. can someone explain the .asm code of it for me?
Mon Sep 23 2019, 07:37 AM
Nathaniel
I am doing a project for my schools wireless security system with cameras,sensors and spot lights using 8051 micro controller, could you help me out with the design and its source code.
Wed Sep 18 2019, 08:48 PM
Caryn Kover
Thank you for your time,
ExperimenterUK
Mon Aug 05 2019, 07:09 PM
@Ismail ..post in forum, give details
Mon Aug 05 2019, 04:33 PM
Ismail balghmi
Hello. Please I won't download
ExperimenterUK
Wed Jul 24 2019, 12:47 AM
@BUSTER123 Please post in the forum
Tue Jul 23 2019, 06:13 PM
BUSTER123
hello! newbie here. i am kind of a guy who hates using ready - made existing libraries, so this helped a lot as i was trying to control and write to a character lcd display. however, i can't figure out how to set the cursor position. for example, i want to set it to the 5th column in the first row, so position 5. so according to the table, i am sending 10000101 on the 8 data lines of the lcd (register select pulled low). the cursor does not move there however. and i cant move the cursor left or right too. is it something wrong that i am doing? thank you.
ExperimenterUK
Thu Jul 11 2019, 07:55 PM
@ramos https://www.theengineeringprojects.com/2017/09/l298-motor-driver-library-proteus.html

Downloads

Comments

ananyagupta
Tue Dec 03 2019, 07:53 AM
wells
Mon Nov 25 2019, 08:25 PM
auwal
Tue Nov 19 2019, 03:13 PM
ANKITPATEL
Mon Nov 18 2019, 11:00 AM
Casmir
Wed Nov 13 2019, 06:25 AM
DeepakBGattani
Mon Nov 11 2019, 01:31 PM
Jeanbusatta
Sun Nov 10 2019, 04:42 AM
mdayaz
Sat Nov 09 2019, 03:41 PM

Online

Guests: 39, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 38107
Newest member: ananyagupta
Forum Activity
ExperimenterUK Avatar
Posted By ExperimenterUK
Fri Nov 29 2019, 04:24 AM
" Is it possible to interface a fingerprint scanne...
ilylily07 Avatar
Posted By ilylily07
Thu Nov 28 2019, 03:50 PM
You will not find any code for an 8051 as no one w...
ExperimenterUK Avatar
Posted By ExperimenterUK
Tue Nov 26 2019, 05:44 PM
You will not find any code for an 8051 as no one w...
ilylily07 Avatar
Posted By ilylily07
Tue Nov 26 2019, 04:13 AM
I tracked down a OV7670 data sheet.The OV7670 puts...
ExperimenterUK Avatar
Posted By ExperimenterUK
Tue Nov 26 2019, 12:08 AM
I tracked down a OV7670 data sheet.The OV7670 puts...
ilylily07 Avatar
Posted By ilylily07
Mon Nov 25 2019, 04:38 PM
The 8051 has too little memory to do anything us...
ExperimenterUK Avatar
Posted By ExperimenterUK
Tue Nov 19 2019, 10:44 PM
The 8051 has too little memory to do anything us...
ilylily07 Avatar
Posted By ilylily07
Mon Nov 18 2019, 09:54 AM
0v7670 camera interfacing with stc 8051.using asse...
Jeanbusatta Avatar
Posted By Jeanbusatta
Sun Nov 10 2019, 04:43 AM
ty, really needed it
ExperimenterUK Avatar
Posted By ExperimenterUK
Tue Oct 22 2019, 05:18 AM