Discussion in "General help Guidance and Discussion" started by    daemotheo    Jan 20, 2010.
Wed Jan 20 2010, 03:59 AM
#1
we're currently doing our project and we are being bugged by our stepper motor... we had seached the net for necessary files, including datasheets and wiring diagrams, but none had helped us.... we're using a 5.1V 1A 200S/R Stepper motor with 6 wire leads......we connected it to a circuit driver, checked and rechecked every component for so many times, yet WE CANNOT MAKE IT TURN!!!!!

HELP US PLEASE.....anyone.
Wed Jan 20 2010, 05:45 AM
#2
have you identify leads?

1a ,1b, 2a,2b

Hope following link will helpful for you.

http://www.embeddedcraft.org/steppermotor.html

--
Gurpreet Singh
http://www.embeddedcraft.org/
Wed Jan 20 2010, 04:34 PM
#3
See if this helps you out:


 shyam like this.
Tags stepper motor wiringstepper motor connectionBLDC motor connection
Wed Jan 20 2010, 09:46 PM
#4
Read the stepper motor tutorial in the Tutorials forum.
If you are still stuck, post your circuit diagram.
Give as much information as possible, about what you have done
and what happened.
Thu Jan 21 2010, 01:42 AM
#5
to Gurpret312:
=>yes, we had identified the leads from the datasheet of the stepper motor.....
=>thanks for the link, it's not much of a help though cause we had the same info from various sites.

to DavesGarage and ExperimenterUK:
+thanks for the info..... but we're still stuck.... here is the schematic we used....with A -> A+ (white/green), B->A-(green), C->B-(red), and D->B+(white/red)....that's the last combination we used...we even tried moving three leads, keeping one lead on place, using different combinations but still, NOTHING HAPPENS....



Thu Jan 21 2010, 05:54 PM
#6
Full article
http://home.cogeco.ca/~rpaisley4/Unipolar.html

Start by removing the motor and replacing each coil with an LED
and resistor.
Then..
Does D1 flash at a sensible steady rate ?.
Do the four test LEDs turn on and off one at a time and in order ?.




Fri Jan 22 2010, 09:51 AM
#7
Sun Jan 24 2010, 06:43 AM
#8
a new idea just came in....i was told that - "maybe we are not generating enough current to run the motor" - AND HE'S RIGHT!...now, may i ask anybody who happens to have a current amplifier circuit?.... i had been searching the web but i cannot find anything that we need or maybe i am looking at the wrong place???? anyone??
Sun Jan 24 2010, 04:29 PM
#9


a new idea just came in....i was told that - "maybe we are not generating enough current to run the motor" - AND HE'S RIGHT!

daemotheo


How do you know he is right ?.

The output of a ULN2003 doubled up, should be enough to at least move your motor
although using four power transistors instead,may be better.

Is the five volt supply to the motor able to supply an amp ?.

Just in case the ULN2003 is burnt out.. replace it.. then add LEDs as I suggested.
See what happens.

Please stop using multi coloured text in your posts, some of it is hard to read.
Tue Jan 26 2010, 12:13 PM
#10
TO ExperimenterUK

How do you know he is right ?.
-we tested the current being supplied to the components....
The output of a ULN2003 doubled up, should be enough to at least move your motor
although using four power transistors instead,may be better.
-ok, we'll give it a try...but how are we going to connect it?....can you give me a schematic diagram? (or if you got a current amplifier circuit, it'll be much better ile)
Is the five volt supply to the motor able to supply an amp ?.
-NOPE....we just found out recently....(we're newbies.....)
Just in case the ULN2003 is burnt out.. replace it.. then add LEDs as I suggested.
See what happens.
-ok, we'll give it a try....
Please stop using multi coloured text in your posts, some of it is hard to read.
-ooppppsss......sorry.


one more thing, we connected LEDs to the part where there should be coil(motor), three of them flashed, two simultaneously while the other alternates, one was not blinking though the LED was in good condition, we suspects that the line/connection to the D coil, the one that didn't blink, which was connected to the 74194(specifically pin 13) was damaged....what do you think?

Get Social

Information

Powered by e107 Forum System

Conversation

ExperimenterUK
Mon Aug 05 2019, 08:09 PM
@Ismail ..post in forum, give details
Mon Aug 05 2019, 05:33 PM
Ismail balghmi
Hello. Please I won't download
ExperimenterUK
Wed Jul 24 2019, 01:47 AM
@BUSTER123 Please post in the forum
Tue Jul 23 2019, 07:13 PM
BUSTER123
hello! newbie here. i am kind of a guy who hates using ready - made existing libraries, so this helped a lot as i was trying to control and write to a character lcd display. however, i can't figure out how to set the cursor position. for example, i want to set it to the 5th column in the first row, so position 5. so according to the table, i am sending 10000101 on the 8 data lines of the lcd (register select pulled low). the cursor does not move there however. and i cant move the cursor left or right too. is it something wrong that i am doing? thank you.
ExperimenterUK
Thu Jul 11 2019, 08:55 PM
@ramos https://www.theengineeringprojects.com/2017/09/l298-motor-driver-library-proteus.html
ExperimenterUK
Thu Jul 11 2019, 08:44 PM
@praveen123. Can you give a link to the project ?
Thu Jul 11 2019, 05:47 PM
ramos
buenos dias alguien podria ayudarme necesito saber como descargar la libreria del l298n para proteus
Thu Jul 11 2019, 12:11 PM
praveen123
anyone can help me
Thu Jul 11 2019, 12:11 PM
praveen123
i need source code for 8051 -smart trolley rfid
Thu Jul 11 2019, 12:10 PM
praveen123
hii

Downloads

Comments

jualanled
Sat Aug 17 2019, 03:41 AM
Wed Aug 07 2019, 10:35 AM
hieu16005
Sat Aug 03 2019, 01:16 PM
Pra
Mon Jul 29 2019, 07:39 AM
manu8193
Wed Jul 24 2019, 04:44 AM
3AAPC
Sun Jul 21 2019, 12:41 AM
rpels7707
Fri Jul 19 2019, 11:31 AM
ameya123
Fri Jul 19 2019, 07:36 AM

Online

Guests: 42, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 38086
Newest member: jualanled
Forum Activity
nick@IT Avatar
Posted By [email protected]
Wed Aug 07 2019, 10:38 AM
I am trying to execute USSD codes through my GSM m...
ExperimenterUK Avatar
Posted By ExperimenterUK
Sun Jul 28 2019, 08:55 PM
An LM339 may not be fast enough for reliable SPI ...
sakibnaz Avatar
Posted By sakibnaz
Sun Jul 28 2019, 06:40 AM
Hi All.I need to connect my MCU with an external S...
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Jul 24 2019, 10:42 PM
Your unit is communicating, so I assume the GPS si...
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Jul 24 2019, 10:32 PM
Have you read this ?http://www.8051projects.net/wi...
manu8193 Avatar
Posted By manu8193
Wed Jul 24 2019, 04:57 AM
any one tell me the explaination and 'c' code for ...
3AAPC Avatar
Posted By 3AAPC
Sun Jul 21 2019, 12:51 AM
3AAPC Avatar
Posted By 3AAPC
Sun Jul 21 2019, 12:47 AM
With the GPS antenna in the outdoors, I use the ub...
ameya123 Avatar
Posted By ameya123
Fri Jul 19 2019, 07:42 AM
Hello,Please share 8051 Assembly language code for...
figureyang Avatar
Posted By figureyang
Fri Jul 05 2019, 04:37 AM
here is the source code prepared for you download ...