Discussion in "Project Doubts" started by    Chinmay Das    Mar 10, 2009.
Tue Mar 10 2009, 06:33 PM
#1
hello ajay sir,

thanking you for ur useful advices, help me to solve the prob of coding errors. Now i require ur help.
i m not able to see the output on the lcd , i m getting only boxes in first line and the second line is empty .
i hv checked all d connections of uC ckt. de r perfect according to the ckt diagram.
i hv tested the ckt with n widout installing d uC... n got the same result. i hv also chek d coding part .it seems der is no prob 4m coding side...

so please help me in that part.






http://www.8051projects.net/files/public/1236709942_14263_FT0_lcd3.jpg]
[/link]





[ Edited Wed Mar 10 2010, 07:06 PM ]
 swarnasugandh like this.
Tue Mar 10 2009, 08:04 PM
#2
here are the codings of LCD initialization

Tue Mar 10 2009, 09:33 PM
#3
try increasing the delay in lcddelay routine. I am sure that will solve your problem.

[Edit]
I just checked your images, you forgot to put controller in circuit.

NOTE: Do check vcc pins to make sure there is 5V


[ Edited Tue Mar 10 2009, 09:43 PM ]
Wed Mar 11 2009, 01:29 AM
#4


try increasing the delay in lcddelay routine. I am sure that will solve your problem.

[Edit]
I just checked your images, you forgot to put controller in circuit.

NOTE: Do check vcc pins to make sure there is 5V

Ajay




Sir i hv checkd both d vcc pt of uC and LCD, i found itz below 5V. So i modified d power supply section n add another 5 V only 4 uC ckt to maintain the voltage drop. And also i hv designed the ckt as per the ckt diagram (ckt images r given below). i m wondering abt the controller in d ckt. cud u pls tell exactly at which pt i miss d controller?

thank you sir 4 ur guide lines....





[ Edited Wed Mar 11 2009, 03:35 PM ]
Wed Mar 11 2009, 03:57 PM
#5


try increasing the delay in lcddelay routine. I am sure that will solve your problem.

[Edit]
I just checked your images, you forgot to put controller in circuit.

NOTE: Do check vcc pins to make sure there is 5V

Ajay




Sir as u told me , i increas d delay in lcddelay 4m 50 to 250. also give const 5v DC supply to uC ckt to maintain the voltage drop. bt i still hv d same problem. i chked d codings thoroughly, bt find no errors. i dnt know hw 2 over com dis prob ... sir pls help me out. i m also uploading codes 4 ur reference.






Wed Mar 11 2009, 06:16 PM
#6


BTW have you tried adjusting the contrast of LCD ?



Arun
Wed Mar 11 2009, 07:04 PM
#7
well sometimes faulty LCD also behave like this
Thu Mar 12 2009, 02:26 AM
#8
hello Arun sir n TPS

ajay sir ask abt the controler , if u give a close look 2 the pix i post b4 i hv used 10k VR 4 adjusting the LCD contrast. Arun Sir i hv chked the resistance btween VR, whn v hv resitsnce in between 6-10K the Lcd contrast is visible.

And TPS , i hv also guessed dat my LCD may b faulty , so i pluged 4 other NEW LCD dat i hv bought 4 other projects. n got d same single line box as result. bt dos LCDs r working perfectly wid other project.

so pls sir tell me wht r the trouble shootings 4 LCD u hv faced duringg u r projects.
so dat i can analysis dem 2 get d solution. or get me any solution on it. thk u

n Happy holi. !dance


[ Edited Thu Mar 12 2009, 08:44 AM ]
Thu Mar 12 2009, 08:45 AM
#9
pls somone help me..........
Thu Mar 12 2009, 08:45 AM
#10
I smell a different problem here..
can you tell me what is LCDDATA is defined?

Get Social

Information

Powered by e107 Forum System

Conversation

Tue Jan 22 2019, 06:51 AM
chnlovelyo
writing
ExperimenterUK
Mon Jan 07 2019, 03:31 AM
@REVOCATUS please post in the AVR forum
Mon Dec 24 2018, 09:25 AM
REVOCATUS MATEMU
sorry I mean referee boards for player substitution
Mon Dec 24 2018, 09:24 AM
REVOCATUS MATEMU
hi am.looking how to build referee by using Atmega 328 and its codes
Sat Dec 15 2018, 01:45 PM
Arslan ayoub
Hii ,, can I get the simulation of numeric keypad lock on proteus
ExperimenterUK
Mon Dec 03 2018, 05:17 PM
Please post questions in the forum. The chat box is for chat
Mon Dec 03 2018, 06:43 AM
help!me!
help! I don't understand busy flag!
Sun Dec 02 2018, 08:01 PM
ile
hello
Mon Nov 12 2018, 05:58 AM
Pavan_user
i have seen your replica of I2C programming using AT89C51 but i am unable to understand the "ack_bit" variable usage ...looks like it is always 1...can you elaborate how acknowledgment is working....
bgk3678
Tue Nov 06 2018, 02:36 PM
kindly any one give solution for my problem

Downloads

Comments

garfield0929
Sun Jan 20 2019, 12:48 AM
servprov
Thu Jan 17 2019, 06:44 AM
marcomilazzo
Wed Jan 16 2019, 04:21 PM
sandhyashree
Wed Jan 16 2019, 04:04 PM
SONACHAI1234
Sun Jan 06 2019, 08:14 AM
manan.gulyaani
Tue Jan 01 2019, 07:58 AM
etech
Sun Dec 30 2018, 07:44 PM
NeilC
Sun Dec 23 2018, 07:39 PM

Online

Guests: 66, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 38039
Newest member: garfield0929
Forum Activity
ExperimenterUK Avatar
Posted By ExperimenterUK
Sun Jan 06 2019, 10:37 PM
Which 8051 chip are you using ?
SONACHAI1234 Avatar
Posted By SONACHAI1234
Sun Jan 06 2019, 08:21 AM
Hi,By mistakenly i burn rx program in my 8051 micr...
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Dec 19 2018, 06:27 PM
Nobody knows?sifirsekizThe problem is that you are...
sifirsekiz Avatar
Posted By sifirsekiz
Wed Dec 19 2018, 12:15 PM
sifirsekiz Avatar
Posted By sifirsekiz
Sun Dec 16 2018, 11:13 PM
Guys pleaseeeee :((
sifirsekiz Avatar
Posted By sifirsekiz
Sat Dec 15 2018, 07:09 PM
HiThe pulse-sensor-amped has an analogue output.Th...
ExperimenterUK Avatar
Posted By ExperimenterUK
Sat Dec 15 2018, 07:01 PM
HiThe pulse-sensor-amped has an analogue output.Th...
sifirsekiz Avatar
Posted By sifirsekiz
Sat Dec 15 2018, 09:02 AM
and ı have pulse sensor one out but anolog use 805...
sifirsekiz Avatar
Posted By sifirsekiz
Sat Dec 15 2018, 08:56 AM
HiMembers can supply code and diagrams if they wan...
ExperimenterUK Avatar
Posted By ExperimenterUK
Fri Dec 14 2018, 11:54 PM
HiMembers can supply code and diagrams if they wan...