Discussion in "Project Doubts" started by    Chinmay Das    Mar 10, 2009.
Tue Mar 10 2009, 06:33 PM
#1
hello ajay sir,

thanking you for ur useful advices, help me to solve the prob of coding errors. Now i require ur help.
i m not able to see the output on the lcd , i m getting only boxes in first line and the second line is empty .
i hv checked all d connections of uC ckt. de r perfect according to the ckt diagram.
i hv tested the ckt with n widout installing d uC... n got the same result. i hv also chek d coding part .it seems der is no prob 4m coding side...

so please help me in that part.






http://www.8051projects.net/files/public/1236709942_14263_FT0_lcd3.jpg]
[/link]





[ Edited Wed Mar 10 2010, 07:06 PM ]
 swarnasugandh like this.
Tue Mar 10 2009, 08:04 PM
#2
here are the codings of LCD initialization

Tue Mar 10 2009, 09:33 PM
#3
try increasing the delay in lcddelay routine. I am sure that will solve your problem.

[Edit]
I just checked your images, you forgot to put controller in circuit.

NOTE: Do check vcc pins to make sure there is 5V


[ Edited Tue Mar 10 2009, 09:43 PM ]
Wed Mar 11 2009, 01:29 AM
#4


try increasing the delay in lcddelay routine. I am sure that will solve your problem.

[Edit]
I just checked your images, you forgot to put controller in circuit.

NOTE: Do check vcc pins to make sure there is 5V

Ajay




Sir i hv checkd both d vcc pt of uC and LCD, i found itz below 5V. So i modified d power supply section n add another 5 V only 4 uC ckt to maintain the voltage drop. And also i hv designed the ckt as per the ckt diagram (ckt images r given below). i m wondering abt the controller in d ckt. cud u pls tell exactly at which pt i miss d controller?

thank you sir 4 ur guide lines....





[ Edited Wed Mar 11 2009, 03:35 PM ]
Wed Mar 11 2009, 03:57 PM
#5


try increasing the delay in lcddelay routine. I am sure that will solve your problem.

[Edit]
I just checked your images, you forgot to put controller in circuit.

NOTE: Do check vcc pins to make sure there is 5V

Ajay




Sir as u told me , i increas d delay in lcddelay 4m 50 to 250. also give const 5v DC supply to uC ckt to maintain the voltage drop. bt i still hv d same problem. i chked d codings thoroughly, bt find no errors. i dnt know hw 2 over com dis prob ... sir pls help me out. i m also uploading codes 4 ur reference.






Wed Mar 11 2009, 06:16 PM
#6


BTW have you tried adjusting the contrast of LCD ?



Arun
Wed Mar 11 2009, 07:04 PM
#7
well sometimes faulty LCD also behave like this
Thu Mar 12 2009, 02:26 AM
#8
hello Arun sir n TPS

ajay sir ask abt the controler , if u give a close look 2 the pix i post b4 i hv used 10k VR 4 adjusting the LCD contrast. Arun Sir i hv chked the resistance btween VR, whn v hv resitsnce in between 6-10K the Lcd contrast is visible.

And TPS , i hv also guessed dat my LCD may b faulty , so i pluged 4 other NEW LCD dat i hv bought 4 other projects. n got d same single line box as result. bt dos LCDs r working perfectly wid other project.

so pls sir tell me wht r the trouble shootings 4 LCD u hv faced duringg u r projects.
so dat i can analysis dem 2 get d solution. or get me any solution on it. thk u

n Happy holi. !dance


[ Edited Thu Mar 12 2009, 08:44 AM ]
Thu Mar 12 2009, 08:45 AM
#9
pls somone help me..........
Thu Mar 12 2009, 08:45 AM
#10
I smell a different problem here..
can you tell me what is LCDDATA is defined?

Get Social

Information

Powered by e107 Forum System

Conversation

Mon Jan 16 2017, 03:15 PM
Rutuja
How can we read notepad file using random acess file
Fri Jan 06 2017, 06:18 AM
muhammad Umar
i need cd4047 library file for protious please help me i s
ExperimenterUK
Wed Jan 04 2017, 09:01 PM
@Emin what is your site user name ?
Tue Jan 03 2017, 11:16 PM
Emin
Emin: I'm already a member since 2012 and entered repeatedly during period. But now it is impossible and obtaining a new registration is also failed. The same error message specifying that two e-mails i entered are different!. In fact thaey are the same. Now, what will be happen, what is your solution? Thanks..
Tue Jan 03 2017, 11:15 PM
Emin
I'm already a member since 2012 and entered repeatedly during period. But now it is impossible and obtaining a new registration is also failed. The same error message specifying that two e-mails i entered are different!. In fact thaey are the same. Now, what will be happen, what is your solution? Thanks..
Sun Jan 01 2017, 03:14 PM
Manoranjana Chary
Write an embedded program of increment and decrement in LCD connected to two keys of int1 and int0. Can u please send me the code for this as fast as possible because i need to submit it in college kindly
ExperimenterUK
Sat Dec 31 2016, 06:28 PM
Happy New Year everyone
ExperimenterUK
Sat Dec 31 2016, 06:27 PM
Please post questions in the forum, the chat box is for chat
Thu Dec 29 2016, 07:47 AM
drashti ranolia
can anyone help me for the microcontroller 8051 programming code for street lights that glow on vehicle movement using IR sensors ?
Tue Dec 27 2016, 11:45 AM
Shubhangi
Do we have to write lookup table for d6t thermal sensor?

Downloads

Comments

sarfrosh92
Sun Jan 15 2017, 09:18 AM
Deepakvaishu
Wed Jan 11 2017, 10:25 AM
rana_jee773
Sat Dec 10 2016, 11:22 AM
[email protected]
Thu Dec 08 2016, 11:02 AM
Jonathan.kei
Mon Nov 21 2016, 04:30 PM
AVRuser1
Sun Nov 20 2016, 06:07 PM
JaguarPaw
Thu Nov 17 2016, 07:44 PM
PeterJohn
Mon Nov 14 2016, 05:54 PM

Online

Guests: 34, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 37796
Newest member: sarfrosh92
Forum Activity
Deepakvaishu Avatar
Posted By Deepakvaishu
Mon Jan 16 2017, 08:31 AM
you are right ..I should not include '\' at t...
Deepakvaishu Avatar
Posted By Deepakvaishu
Mon Jan 16 2017, 06:07 AM
No ,its not the null character, its just the '...
sankalp_s Avatar
Posted By sankalp_s
Sun Jan 15 2017, 07:55 PM
There is a fault in your Proteus design.If you loo...
sarfrosh92 Avatar
Posted By sarfrosh92
Sun Jan 15 2017, 10:04 AM
The 8051 Microcontroller (3rd Edition) by I. Scott...
ExperimenterUK Avatar
Posted By ExperimenterUK
Sat Jan 14 2017, 11:59 PM
The site editor may have removed the 0 from \0.Actually it should not be needed, sochar *phone_no[3 ]={"1234567890" ," 9087654321" ,"76676667676"}; //array of pointers should work.
ExperimenterUK Avatar
Posted By ExperimenterUK
Sat Jan 14 2017, 11:54 PM
There is a fault in your Proteus design.If you loo...
sankalp_s Avatar
Posted By sankalp_s
Fri Jan 13 2017, 06:52 PM
Hi phill sir.. testButton1: ...
Deepakvaishu Avatar
Posted By Deepakvaishu
Fri Jan 13 2017, 11:58 AM
suppose i have this arraychar *phone_no[3 ]={"1234...
ajay_bhargav Avatar
Posted By ajay_bhargav
Fri Jan 13 2017, 05:59 AM
You need to send AT command one by one to all the ...
Deepakvaishu Avatar
Posted By Deepakvaishu
Wed Jan 11 2017, 10:47 AM
How to send the same message to multiple contacts ...