Discussion in "Embedded GSM Development" started by    mangesh24    Sep 24, 2011.
Sat Sep 24 2011, 10:19 PM
#1
Hi friends,
I am trying to send SMS using GSM modem, after i send destination mobile number I am receiving "\r\n> " as a response from modem , after i enter text to message, i terminated it with "0x1A" character, further i am getting response as "\r\n" from the modem but not \r\nOK\r\n. Can anyone tell me the possible error?
for what time i should wait for receiving the ok response?
Please help
Sun Sep 25 2011, 12:17 PM
#2
@ mangesh24
ru using sim300dz modem or any other
ru checking it on hyper terminal or doing with controller
if using controller post code
Mon Sep 26 2011, 09:13 PM
#3
@majoka, Thanks for the reply.
While debugging this problem, i found one another problem with getting connected to wireless network,
If i send the AT+CRQ command to ask signal strength, i got the response as "error: operation not allowed", currently i am trying to solve this issue, also i get CREG response as 0,0 so might be i need to do more for establishing the connection with GSM network(The setting is Auto connect by-default).
Please help me more on this.
Thanks for the reply.
Mon Sep 26 2011, 09:16 PM
#4
@majoka,
Sorry,forgot to answer your questions,
I am using Sierra wireless GSM modem SL8082 family with micro-controller.
Tue Sep 27 2011, 09:53 AM
#5


@majoka,
Sorry,forgot to answer your questions,
I am using Sierra wireless GSM modem SL8082 family with micro-controller.

mangesh24



All GSM modems are wireless.
Do you have datasheet/brochure of SL8082. i am not finding it.
Before connecting to controller did you checked response on hyper terminal?
Tue Sep 27 2011, 10:44 AM
#6
Wed Sep 28 2011, 09:10 AM
#7
hello sir;
sir i have completed receiving SMS through GSM module(sim300) .now i want to send SMS to any other mobile from my GSM module .plz help me in the sense at command to send sms (any data) to any other mobile.


Thankyou!
Wed Sep 28 2011, 09:23 AM
#8
Hi,
Which controller are you using?
Test this in your hyper terminal first.
AT+CMGS="9845XXXXX"(ENTER)
>Type your msg here and press ctrl+z to send the msg.

The same thing you implement in your design.
Share your code for more understanding.
Wed Sep 28 2011, 11:48 AM
#9
@ dspicmicro
follow kiran suggestion
also same logic is in controller as well as on hyper terminal
Thu Dec 15 2011, 03:00 AM
#10
try this code,hope it helps
void send_sms(char phonE[15],char *m)
{

fprintf(SIM300,"AT+CMGS=");
putc(34);//char "

fprintf(SIM300,phonE);
putc(34);//char "

putc(13);//enter CR
delay_ms(1000);//waiting for char ">"
fprintf(SIM300,m);
delay_ms(1000);
putc(26);//CTRL+Z => start send message

}

Get Social

Information

Powered by e107 Forum System

Conversation

hiast
Thu Jun 16 2016, 03:03 PM
help please how do i initiate port 3 as an input port in assembly? acutely there is push switch connecting to p3.2 push switch connecting to p3. 3 push switch connecting to p3.4 push switch connecting to p3.5 and i need to call function when the user pressed the push switch for the previous pins (not used as counter and not as timer… just call a function ( do special thing) when any push switch is pressed ???????
Mon Jun 06 2016, 12:02 PM
nida hussain
hi.. i need some help with keypad interfacing code.like i want to write a code in c language that takes an input of 2 digit numbers from a keypad interfaced with 8051 mc and stores the entered values in some array
Sat May 28 2016, 04:34 PM
kibrom berhe
c code for locker security system based on rfid and gsm
ExperimenterUK
Wed May 25 2016, 05:05 AM
@ Ramanjaneyulu, post in forum,explain your problem
Mon May 23 2016, 11:34 PM
Ramanjaneyulu
Hi, I Am using at89c4051 for my application, I want 5u sec dely.. Up to 1milli sec iam able to producing delay. Beyond the 1milli second, I am unable to produce the acceurate dely. Plz any one help me
Sat May 21 2016, 09:51 PM
A K
i want to mak an auto dialer using gsm and atmega 16. please helpe me how to write a code to auto dial a number saved in sim
Sat May 21 2016, 10:42 AM
Alec
Hi im trying to program my 89s51 with a usbasp so any ideas on the circuit?
Wed May 18 2016, 10:08 AM
Tashu joshi
anyone know how to develop
Wed May 18 2016, 10:07 AM
Tashu joshi
i'm working for resporatry system using 8051,
Wed May 18 2016, 10:06 AM
Tashu joshi
i'm developing a respiratory system using Arduino

Downloads

Comments

dyoussef
Wed Jun 29 2016, 07:29 PM
sung7333
Tue Jun 28 2016, 06:23 AM
Bonolai
Fri Jun 24 2016, 06:02 AM
hiast
Sat Jun 11 2016, 02:30 PM
alex1311
Thu Jun 09 2016, 06:57 AM
zaft93
Sun May 15 2016, 01:52 AM
CELEBI
Thu May 12 2016, 08:28 AM
Suro1996
Wed May 11 2016, 06:07 PM

Online

Guests: 36, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 37770
Newest member: dyoussef
Forum Activity
dyoussef Avatar
Posted By dyoussef
Wed Jun 29 2016, 07:34 PM
Hello, I am referencing this project: http://www.8051projects.net/wiki/I2C_Implementation_on_PICI am using PIC16F1847 and XC8 so I've had to make a few changes to the code. While making changes, my compiler gave me an error for the I2CWait function for the while statement. It says "unexpected token amp". Here is the line in question:while ((SSPCON2 & 0x1F ) || ( SSPSTAT & 0x04 ) );I changed the register names to be consistent with my PIC but it didn't solve the problem.What changes do I need to make to this function so that this error does not occur?
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Jun 22 2016, 07:54 PM
I can't see why it should work sometimes and not o...
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Jun 22 2016, 12:58 AM
You could use T0 and T1 to trigger interrupts but ...
Karan123 Avatar
Posted By Karan123
Tue Jun 21 2016, 04:40 AM
I am not Getting you . the project is to interfac...
Karan123 Avatar
Posted By Karan123
Tue Jun 21 2016, 04:34 AM
Hello,Thanks , It Works . Master-Slave address Ma...
alex1311 Avatar
Posted By alex1311
Mon Jun 20 2016, 11:38 AM
Football is my passion and I have dreamt of becomi...
ExperimenterUK Avatar
Posted By ExperimenterUK
Fri Jun 17 2016, 11:00 PM
>But Can't modify code at Receiver End for Differe...
hiast Avatar
Posted By hiast
Fri Jun 17 2016, 03:25 PM
thanks for help,i wanted to write this code as you...
Karan123 Avatar
Posted By Karan123
Fri Jun 17 2016, 12:19 PM
I don't your applications . But below should help ...
Karan123 Avatar
Posted By Karan123
Fri Jun 17 2016, 12:07 PM
I know i have to use below code at Transmitter End...