Discussion in "Project Help" started by    kakshay92    Jul 7, 2012.
Sat Jul 07 2012, 10:04 AM
#1
I am trying to make the "Cellphone operated Land Rover" project given in the EFY magazine, pdf attached.

The H-Bridge IC circuit is working properly and to my knowledge, everything in the MT8870 DTMF Decoder IC circuit is also soldered correctly.

I am using Nokia 2300 for my project and the original earphones that came with it. They work properly when listening to radio, or talking to someone over the phone.

However, the MT8870 IC does not give output when I connect it to my AT89S52 microcontroller. I have written a simple program to transfer everything from port 0 to port 1 (in which an LED board is connected) - so that the corresponding output of the MT8870 (binary) will be shown on the LED board. But it continuously shows 0000, even on pressing keys.

The connector for my phone is of the TRRS type - and my speaker wires have connection to TIP and the second RING.

Please assist me in my project. I am unable to understand where I have gone wrong.
Sat Jul 07 2012, 08:15 PM
#2
first u should get the dtmf o/p ....
in u r case check the crystal ,discreate components especialy capacitor.....
to see the tone is recive see the strobe pin on decoder ic ..when tone recive this pin is hi .....it means tone recived propely

''However, the MT8870 IC does not give output when I connect it to my AT89S52 microcontroller.''
means you get the o/p when micro is removed.....if this is problem see the ground connections of both are connected propely by a continouty test....
Sun Jul 08 2012, 07:19 AM
#3
How do I check the crystal and capacitors?

I will try the strobe pin, thank you for that idea!
Sun Jul 08 2012, 06:15 PM
#4


How do I check the crystal and capacitors?

kakshay92


If you don't have use of an oscilloscope the best way is to replace
the capacitors,then the crystal.

Check your soldering carefully.
Sun Jul 08 2012, 07:13 PM
#5
@ kakshay92
attach circuit according to this schematic

i test it and it is working ok
first u has to be able to get out put of the decoder ic then go to controller that is second step
u can use this software to generate the DTMF tones in the pc or laptop
http://www.polar-electric.com/DTMF/InstallDTMFencoder.exe
use headphone with the laptop and connect it with the circuit
now when laptop generate DTMF tones according to that led showw the status of the ic output
is is an easy and cost free method to check dtmf ic
i use this program is so useful
use stereo connector with laptop to IC connection
 kakshay92 like this.
Mon Jul 09 2012, 04:44 AM
#6
I would be better if you check just the MT8870 receiver part first, remove your microcontroller and see the output of DTMF decoder using multimeter. this will ensure that a part of your circuit is working fine. then you can check controller side if things are going wrong.
Mon Jul 09 2012, 03:35 PM
#7
Thank you everyone for your efforts! I went to my instructor and he suggested a few resistors and capacitor changes, am going to try that and hope it will work!
Mon Jul 09 2012, 05:56 PM
#8
Good Luck kakshay92
 kakshay92 like this.

Get Social

Information

Powered by e107 Forum System

Conversation

ExperimenterUK
Tue Jul 19 2016, 05:59 PM
@mhammad 64 bits is 8 bytes.
Tue Jul 19 2016, 07:56 AM
mhammad kassem
hello! i want to know how to use UART in mikroc , I want to receive 64 bits from another microcontroller and i dont know how to start my code to receive the 64 bits...any help?
ExperimenterUK
Mon Jul 18 2016, 08:32 PM
@meena.. are you still having trouble ?
Sat Jul 16 2016, 10:19 AM
Meena
problem in loading email address while registering.Please help
Sun Jul 10 2016, 02:50 PM
shockwave
could you please provide a sample code that controling LED using bluetooth HC-05 interfacing pic16f877a thank you!
Sun Jul 10 2016, 02:49 PM
shockwave
Help!
ExperimenterUK
Sat Jul 09 2016, 05:25 PM
@Santhana krishnan post in forum to discuss your problem
Thu Jul 07 2016, 09:26 AM
Santhana krishnan
Hi i program atmega 32 it was functiining corectly but now aref pins voltage 2.56 is droped to .85 volts also a ports input viltage also dropped so anologe inpit not funcitonig please help me to find out the problem
Thu Jul 07 2016, 09:24 AM
Santhana krishnan
Hi i program the atmega 32
Thu Jul 07 2016, 09:24 AM
Santhana krishnan
Hi

Downloads

Comments

adithyapaip
Thu Jul 21 2016, 05:45 PM
celu
Thu Jul 21 2016, 05:27 PM
Aiko
Wed Jul 20 2016, 01:51 PM
JorgeG
Sat Jul 16 2016, 07:19 PM
Piotrekk
Wed Jul 06 2016, 09:35 AM
dyoussef
Wed Jun 29 2016, 07:29 PM
sung7333
Tue Jun 28 2016, 06:23 AM
Bonolai
Fri Jun 24 2016, 06:02 AM

Online

Guests: 50, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 37775
Newest member: adithyapaip
Forum Activity
ExperimenterUK Avatar
Posted By ExperimenterUK
Sat Jul 23 2016, 07:14 PM
I found this datasheet, it is a type of driver.It ...
Piotrekk Avatar
Posted By Piotrekk
Fri Jul 22 2016, 10:12 AM
I found an old box of electronic components in the...
ExperimenterUK Avatar
Posted By ExperimenterUK
Thu Jul 21 2016, 07:37 PM
That is curious, but very likely a co-incidence.Th...
adithyapaip Avatar
Posted By adithyapaip
Thu Jul 21 2016, 07:18 PM
I am using keil to do everthing in 8051,when I was...
ExperimenterUK Avatar
Posted By ExperimenterUK
Thu Jul 21 2016, 07:14 PM
By far the easiest and cheapest way to talk to the...
ExperimenterUK Avatar
Posted By ExperimenterUK
Thu Jul 21 2016, 07:04 PM
The crystal on the programmer does not affect the ...
adithyapaip Avatar
Posted By adithyapaip
Thu Jul 21 2016, 06:06 PM
Hi Guys..i have a 8051 programmer which has 4mhz c...
Aiko Avatar
Posted By Aiko
Wed Jul 20 2016, 01:56 PM
ankitbajaj01 Avatar
Posted By ankitbajaj01
Wed Jul 20 2016, 04:49 AM
Dear All,Greetings!!!I want to develop Online moni...
sairfan1 Avatar
Posted By sairfan1
Tue Jul 19 2016, 09:56 PM
Now a days there are many smart locks available li...