Discussion in "Project Doubts" started by    sankalp_s    Nov 29, 2014.
Tue Jan 05 2016, 06:19 PM
#61


Do they both give the same result ?

Try this minimal version..does it work ?.



ExperimenterUK


yes sir both give same result.
sir, in this minimal version i can see the rotation on pins but when i connect the leds it gives same result as before i described.
sir are you sure code is ok?
Fri Jan 08 2016, 05:56 PM
#62
The minimal version works, so the logic is okay.
As far as I can see, adding the LEDs should make no difference
to the simulation.

I suggest you add your components to the minimal circuit
one bit at a time and see where it stops working.

Let us know what happens.
Thu Jan 21 2016, 04:31 AM
#63
@ sankalp_s
i fell that problem is in hardware
let me tell one thing when all port is high and all port is low what is status of your leds
if no status change then its like a switching problem or some soldering issue in hardware
Proteus do not need a lot of components for simulation
it just need hex file and oscillator speed to verify your logic
Mon Jan 25 2016, 07:02 PM
#64




I suggest you add your components to the minimal circuit
one bit at a time and see where it stops working.

Let us know what happens.

ExperimenterUK


sir i have tried too many times, after adding more than two leds same problem occurs.
Mon Jan 25 2016, 07:16 PM
#65


@ sankalp_s
i fell that problem is in hardware
let me tell one thing when all port is high and all port is low what is status of your leds
if no status change then its like a switching problem or some soldering issue in hardware
Proteus do not need a lot of components for simulation
it just need hex file and oscillator speed to verify your logic

majoka


hello sir, thank u for your interest ,
sir, I have tried this code with a complete pcb(led chaser) having same components where other programmed microcontroller (came with this pcb) works fine but my code gives same result.
even output pins are same.
Tue Jan 26 2016, 10:21 PM
#66
Make sure the push button input pins are pulled high.

This program will do what Majoka suggested... turn all LEDs on and off in a loop.

Try it in your hardware and let us know what happens
and how fast they switch.

Which micro are you using. ?
Is it exactly the same as the one on the board you bought ?

Attachment


[ Edited Tue Jan 26 2016, 10:22 PM ]
Thu Jan 28 2016, 06:36 PM
#67


Make sure the push button input pins are pulled high.

This program will do what Majoka suggested... turn all LEDs on and off in a loop.

Try it in your hardware and let us know what happens
and how fast they switch.



Attachment

ExperimenterUK


sir this code is working fine in my hardware. and switching time is near about 1 sec.

Which micro are you using. ?
Is it exactly the same as the one on the board you bought ?


i'm using at89c52, same as that one.....push buttons are also pulled high.



[ Edited Thu Jan 28 2016, 06:37 PM ]
Thu Jan 28 2016, 11:18 PM
#68
Okay I took another look at your problem
and I think I know the answer.


problem is in chaser pattern when four led get off(as per code instruction) at same time, same leds blink with very low light.as per instructions lesds should not be blinked.

sankalp_s



Your code says..
DESGN8: 
                CALL DELAY
		CALL ALLON
                CLR L1
                CLR L2
                CLR L3
                CLR L4
                CALL DELAY
                CALL ALLON
                CLR L2
                CLR L3
                CLR L4
                CLR L5
                CALL DELAY
                CALL ALLON
                CLR L3
                CLR L4
                CLR L5
                CLR L6
                CALL DELAY
                CALL ALLON
                CLR L4
                CLR L5
                CLR L6
                CLR L7



You turn the LEDS off for a long time then on for a very short time.
Because the on time is so short the LED appears to glow dimly/blink


Make sure P3.5 is pulled high as well.


[ Edited Thu Jan 28 2016, 11:20 PM ]
 sankalp_s like this.
Fri Jan 29 2016, 06:57 PM
#69


You turn the LEDS off for a long time then on for a very short time.
Because the on time is so short the LED appears to glow dimly/blink



ExperimenterUK


ok sir but what is solution for it. will i have to dump this code?


Make sure P3.5 is pulled high as well.


yes p3.5 is pulled high.


[ Edited Fri Jan 29 2016, 06:58 PM ]
Sat Jan 30 2016, 12:40 AM
#70


ok sir but what is solution for it. will i have to dump this code?

sankalp_s


The code works.
But what you tell it to do is wrong.

To turn LEDs on then off so you can see the effect just add
delays between each change.
For example...
DESGN8: 

		CALL ALLON
                CLR L1
                CLR L2
                CLR L3
                CLR L4
                CALL DELAY  ;delay to see  leds off
                CALL ALLON
                CALL DELAY  ;add a delay to see all leds on
                CLR L2
                CLR L3
                CLR L4
                CLR L5
                CALL DELAY   ;delay to see  leds off
                CALL ALLON
                CALL DELAY  ;add a delay to see all leds on
                CLR L3
                CLR L4
                CLR L5
                CLR L6
               


[ Edited Sat Jan 30 2016, 12:43 AM ]

Get Social

Information

Powered by e107 Forum System

Conversation

DavesGarage
Tue Jan 09 2018, 07:55 PM
It's been a few years since I poked around here - Hi all...
ExperimenterUK
Mon Jan 08 2018, 07:19 PM
Hi TPS. it's been a while..
۞ TPS ۞
Sun Jan 07 2018, 06:42 PM
hello
Thu Jan 04 2018, 01:50 PM
sayyad affrid
its AT89S52
Thu Jan 04 2018, 01:50 PM
sayyad affrid
sir, i want embedded c code for ultrasonic sensor having buzzer interfaced with AT9S52
Mon Dec 18 2017, 08:12 PM
zafir
i am making digital voltmeter using AT89C51, ADC and LCD 16x2,,, kindly someone please send me hex file in assembly language
Fri Dec 15 2017, 12:18 PM
mehari
can not find dhtxx.md file in proteus 8.0 can anybody help me please?
sahar7478
Fri Dec 08 2017, 12:47 PM
can i get gsm a6 library? can anybody help? tia
Faiqa
Sat Nov 25 2017, 08:32 AM
Can i get the code of Monitering and controlling of green house effect? ... Can anyone help me ?
Wed Nov 08 2017, 01:35 PM
Anirudh jain
I want to burn code in atmel 89s51 24pc 0329 but cannot get the connection with the burner. Can somebody provide me with the circuit diagram for connecting controller to burner. I'm using usb burner

Downloads

Comments

vieslav
Thu Jan 18 2018, 06:19 PM
eddieprice
Fri Jan 12 2018, 04:07 PM
bastik
Fri Jan 12 2018, 09:36 AM
cjj20
Tue Jan 09 2018, 07:29 PM
shahzadiqbal
Tue Jan 09 2018, 01:57 PM
shailu1809
Mon Jan 08 2018, 01:11 AM
saffrid97
Sun Jan 07 2018, 01:48 AM
vietbac
Sat Jan 06 2018, 10:08 AM

Online

Guests: 32, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 37944
Newest member: vieslav
Forum Activity
ExperimenterUK Avatar
Posted By ExperimenterUK
Sat Jan 13 2018, 10:26 PM
This is clearly an old design.A modern microcontr...
bastik Avatar
Posted By bastik
Sat Jan 13 2018, 09:38 PM
For now I don’t have much information about device...
ExperimenterUK Avatar
Posted By ExperimenterUK
Fri Jan 12 2018, 06:49 PM
Sometimes the Configuration word has to be program...
ExperimenterUK Avatar
Posted By ExperimenterUK
Fri Jan 12 2018, 06:30 PM
What exactly is your situation ?I very much doubt ...
eddieprice Avatar
Posted By eddieprice
Fri Jan 12 2018, 04:32 PM
I am using a 16F84A for the first time and am havi...
bastik Avatar
Posted By bastik
Fri Jan 12 2018, 10:37 AM
I have device with SAB80C535 microcontroller and I...
ExperimenterUK Avatar
Posted By ExperimenterUK
Fri Jan 12 2018, 12:01 AM
I tried to compile your 8051 version in Keil 5but...
cjj20 Avatar
Posted By cjj20
Tue Jan 09 2018, 07:42 PM
I just think something is off in the checkgpgga fu...
ExperimenterUK Avatar
Posted By ExperimenterUK
Tue Jan 09 2018, 07:35 PM
Why do you think there is something wrong with it...
cjj20 Avatar
Posted By cjj20
Tue Jan 09 2018, 07:32 PM
Please help me correct this code #include ...