Discussion in "Project Doubts" started by    sankalp_s    Nov 29, 2014.
Tue Jan 05 2016, 06:19 PM
#61


Do they both give the same result ?

Try this minimal version..does it work ?.



ExperimenterUK


yes sir both give same result.
sir, in this minimal version i can see the rotation on pins but when i connect the leds it gives same result as before i described.
sir are you sure code is ok?
Fri Jan 08 2016, 05:56 PM
#62
The minimal version works, so the logic is okay.
As far as I can see, adding the LEDs should make no difference
to the simulation.

I suggest you add your components to the minimal circuit
one bit at a time and see where it stops working.

Let us know what happens.
Thu Jan 21 2016, 04:31 AM
#63
@ sankalp_s
i fell that problem is in hardware
let me tell one thing when all port is high and all port is low what is status of your leds
if no status change then its like a switching problem or some soldering issue in hardware
Proteus do not need a lot of components for simulation
it just need hex file and oscillator speed to verify your logic
Mon Jan 25 2016, 07:02 PM
#64




I suggest you add your components to the minimal circuit
one bit at a time and see where it stops working.

Let us know what happens.

ExperimenterUK


sir i have tried too many times, after adding more than two leds same problem occurs.
Mon Jan 25 2016, 07:16 PM
#65


@ sankalp_s
i fell that problem is in hardware
let me tell one thing when all port is high and all port is low what is status of your leds
if no status change then its like a switching problem or some soldering issue in hardware
Proteus do not need a lot of components for simulation
it just need hex file and oscillator speed to verify your logic

majoka


hello sir, thank u for your interest ,
sir, I have tried this code with a complete pcb(led chaser) having same components where other programmed microcontroller (came with this pcb) works fine but my code gives same result.
even output pins are same.
Tue Jan 26 2016, 10:21 PM
#66
Make sure the push button input pins are pulled high.

This program will do what Majoka suggested... turn all LEDs on and off in a loop.

Try it in your hardware and let us know what happens
and how fast they switch.

Which micro are you using. ?
Is it exactly the same as the one on the board you bought ?

Attachment


[ Edited Tue Jan 26 2016, 10:22 PM ]
Thu Jan 28 2016, 06:36 PM
#67


Make sure the push button input pins are pulled high.

This program will do what Majoka suggested... turn all LEDs on and off in a loop.

Try it in your hardware and let us know what happens
and how fast they switch.



Attachment

ExperimenterUK


sir this code is working fine in my hardware. and switching time is near about 1 sec.

Which micro are you using. ?
Is it exactly the same as the one on the board you bought ?


i'm using at89c52, same as that one.....push buttons are also pulled high.



[ Edited Thu Jan 28 2016, 06:37 PM ]
Thu Jan 28 2016, 11:18 PM
#68
Okay I took another look at your problem
and I think I know the answer.


problem is in chaser pattern when four led get off(as per code instruction) at same time, same leds blink with very low light.as per instructions lesds should not be blinked.

sankalp_s



Your code says..
DESGN8: 
                CALL DELAY
		CALL ALLON
                CLR L1
                CLR L2
                CLR L3
                CLR L4
                CALL DELAY
                CALL ALLON
                CLR L2
                CLR L3
                CLR L4
                CLR L5
                CALL DELAY
                CALL ALLON
                CLR L3
                CLR L4
                CLR L5
                CLR L6
                CALL DELAY
                CALL ALLON
                CLR L4
                CLR L5
                CLR L6
                CLR L7



You turn the LEDS off for a long time then on for a very short time.
Because the on time is so short the LED appears to glow dimly/blink


Make sure P3.5 is pulled high as well.


[ Edited Thu Jan 28 2016, 11:20 PM ]
 sankalp_s like this.
Fri Jan 29 2016, 06:57 PM
#69


You turn the LEDS off for a long time then on for a very short time.
Because the on time is so short the LED appears to glow dimly/blink



ExperimenterUK


ok sir but what is solution for it. will i have to dump this code?


Make sure P3.5 is pulled high as well.


yes p3.5 is pulled high.


[ Edited Fri Jan 29 2016, 06:58 PM ]
Sat Jan 30 2016, 12:40 AM
#70


ok sir but what is solution for it. will i have to dump this code?

sankalp_s


The code works.
But what you tell it to do is wrong.

To turn LEDs on then off so you can see the effect just add
delays between each change.
For example...
DESGN8: 

		CALL ALLON
                CLR L1
                CLR L2
                CLR L3
                CLR L4
                CALL DELAY  ;delay to see  leds off
                CALL ALLON
                CALL DELAY  ;add a delay to see all leds on
                CLR L2
                CLR L3
                CLR L4
                CLR L5
                CALL DELAY   ;delay to see  leds off
                CALL ALLON
                CALL DELAY  ;add a delay to see all leds on
                CLR L3
                CLR L4
                CLR L5
                CLR L6
               


[ Edited Sat Jan 30 2016, 12:43 AM ]

Get Social

Information

Powered by e107 Forum System

Conversation

Tue Jul 23 2019, 08:33 AM
Constance Sutherland
ss内容ss
ExperimenterUK
Thu Jul 11 2019, 07:55 PM
@ramos https://www.theengineeringprojects.com/2017/09/l298-motor-driver-library-proteus.html
ExperimenterUK
Thu Jul 11 2019, 07:44 PM
@praveen123. Can you give a link to the project ?
Thu Jul 11 2019, 04:47 PM
ramos
buenos dias alguien podria ayudarme necesito saber como descargar la libreria del l298n para proteus
Thu Jul 11 2019, 11:11 AM
praveen123
anyone can help me
Thu Jul 11 2019, 11:11 AM
praveen123
i need source code for 8051 -smart trolley rfid
Thu Jul 11 2019, 11:10 AM
praveen123
hii
ExperimenterUK
Thu Jun 27 2019, 09:14 PM
Hi.. good to see you again
۞ TPS ۞
Thu Jun 27 2019, 07:31 AM
Hello
AdiGhazi
Tue Jun 18 2019, 11:21 AM
Hlo Dear , I've to program AT89C51AC3 RT-LUM using flip but I'm getting time out error for RS232. Will you please suggest me which programmer will be supportable to program this Chip.

Downloads

Comments

3AAPC
Sun Jul 21 2019, 12:41 AM
rpels7707
Fri Jul 19 2019, 11:31 AM
ameya123
Fri Jul 19 2019, 07:36 AM
anhsieuno
Thu Jul 18 2019, 11:39 AM
zxcvbnm1234
Sat Jul 13 2019, 07:09 AM
surajghayal
Wed Jul 10 2019, 01:17 PM
figureyang
Fri Jul 05 2019, 04:25 AM
mousompal
Sat Jun 29 2019, 05:02 PM

Online

Guests: 62, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 38081
Newest member: 3AAPC
Forum Activity
3AAPC Avatar
Posted By 3AAPC
Sun Jul 21 2019, 12:51 AM
3AAPC Avatar
Posted By 3AAPC
Sun Jul 21 2019, 12:47 AM
With the GPS antenna in the outdoors, I use the ub...
ameya123 Avatar
Posted By ameya123
Fri Jul 19 2019, 07:42 AM
Hello,Please share 8051 Assembly language code for...
figureyang Avatar
Posted By figureyang
Fri Jul 05 2019, 04:37 AM
here is the source code prepared for you download ...
figureyang Avatar
Posted By figureyang
Fri Jul 05 2019, 04:30 AM
Cheap_Flash_FS(Normal Version)--Embedded FAT16/32 ...
wimac Avatar
Posted By wimac
Sat Jun 22 2019, 01:26 PM
I’ve use the AT89C51ED2 which has a similar progra...
ExperimenterUK Avatar
Posted By ExperimenterUK
Thu Jun 20 2019, 10:08 PM
baud rate is 9600 at stop bits of 2. AdiGhaziThe u...
AdiGhazi Avatar
Posted By AdiGhazi
Thu Jun 20 2019, 05:24 AM
Dear,I'm using RS232 serial port cable to use flip...
ExperimenterUK Avatar
Posted By ExperimenterUK
Tue Jun 18 2019, 10:19 PM
Okay.. I have never programmed the AT89C51AC3 or ...
AdiGhazi Avatar
Posted By AdiGhazi
Tue Jun 18 2019, 11:20 AM
Hlo Dear ,I've to program AT89C51AC3 RT-LUM using ...