Discussion in "Project Doubts" started by    LAMBO    Apr 12, 2018.
Thu Apr 12 2018, 06:51 PM
#1
hii sir,
I am working on ac motor controller .I have connected circuit as per given circuit diagram but sir instead of this
sbit led1 = p3^7;
sbit led2 = p3^6;
rest all led are glowing
and sir i don't get output on optocoupler as well
and sir innstead of 9v transformer I have used 9 volt battery as input.
plz help me out
is something wrong with program code..
Fri Apr 13 2018, 02:09 AM
#2
I assume you are doing this project.
http://www.8051projects.net/download-d238-single-phase-ac-motor-speed-controller-project-report.html

In that case it will not work if you replace the 9v transformer with a battery.
The transformer provides a timing signal.

The LEDs should still change when you press the buttons.
Have you got a serial connection to your PC ?
Mon Apr 16 2018, 06:39 AM
#3
Hi sir
i haven't connected any serial connection to pcb to pc i am controlling my speed of motor by means of switch sw2 and sw3
sir isn't any problem if i control my speed of motor by means of switch sw2 and sw3 ?? and sir how a transformer can provide a timing signal ?

Mon Apr 16 2018, 08:49 PM
#4
On the diagram, a diode feeds a rectified sine wave to R1.
The circuit feeds a signal to P3.2 (INT 0) at the low point.
This pulse is needed to time the output on P0.0

Using a battery you will not get an output on P0.0
but you should still see the LEDs on port 2 change
as you press buttons SW2 and SW3

>Sir isn't any problem if i control my speed of motor
>by means of switch sw2 and sw3 ??
No problem, I ask because a serial link can be useful for testing.
It is easy to add with a USB/Serial adapter.

The 240 volt circuit seems close to the low voltage side.
240 volts can kill.

Move the 240 volt circuit and MOC3011 to a separate board.


[ Edited Mon Apr 16 2018, 10:25 PM ]
Fri Apr 27 2018, 05:33 PM
#5
Hi sir

       I have connected circuit as per given circuit diagram every thing is working fine and mine optocoupler is showing ouptut as well but sir mine fan is not showing any response even though i am pressing increment and decrement switch and i am using exhaust fan and in snubber circuit i have kept  R value as 390 ohm and C value is 103/1kw and sir i have also connected 200 watt bulb in place of exhaust fan but its same it also not showing any response
Fri Apr 27 2018, 08:03 PM
#6
Using a light bulb is a good idea.

Disconnect the mains side of things while testing.

Fit an LED in place of the control side of the MOC3011.
That is.
Disconnect the MOC3011 and put an LED between the 220ohm
resistor and the 8051 pin 39. (port 0.0)


It should turn on and off and vary in response to to buttons.

Do the indicator LEDs change as expected ?




[ Edited Fri Apr 27 2018, 08:08 PM ]
Sat Apr 28 2018, 08:00 AM
#7
Hi sir
as u told i have connected led between 220 ohm resistor and pin 39 and the led turn on and off and vary in response to buttons as expected
Sat Apr 28 2018, 08:33 PM
#8
If the LED is turning on and off and varying, then the fault is
on the mains side.
Does the light turn on and off when connected to the micro ?
If it is always on, you have a faulty triac, or your wiring
is wrong.
Mon Apr 30 2018, 10:33 AM
#9
Since we are in india working output is 240VAC and 50HZ. I tried moc2021 with BT136 as following connections. Fan is getting on without any firing of triac. Also the 460 Ohms resistance heats up.

Mon Apr 30 2018, 06:48 PM
#10
You say you used a MOC2021, I can't find a data sheet , is it a MOC2021 ?

Okay.. so current is flowing to the motor ,we need to find out how.
First change the motor to a light bulb, say 100Watts. it will give a better idea of how
much current is flowing.

Is it full brightness ?
Next remove the opto-isolator.
Any change ?
Remove 360 ohm resistor and 0.05Uf cap
Any change ?
Remove BT136.
Report back.

Get Social

Information

Powered by e107 Forum System

Conversation

Tue Jul 23 2019, 08:33 AM
Constance Sutherland
ss内容ss
ExperimenterUK
Thu Jul 11 2019, 07:55 PM
@ramos https://www.theengineeringprojects.com/2017/09/l298-motor-driver-library-proteus.html
ExperimenterUK
Thu Jul 11 2019, 07:44 PM
@praveen123. Can you give a link to the project ?
Thu Jul 11 2019, 04:47 PM
ramos
buenos dias alguien podria ayudarme necesito saber como descargar la libreria del l298n para proteus
Thu Jul 11 2019, 11:11 AM
praveen123
anyone can help me
Thu Jul 11 2019, 11:11 AM
praveen123
i need source code for 8051 -smart trolley rfid
Thu Jul 11 2019, 11:10 AM
praveen123
hii
ExperimenterUK
Thu Jun 27 2019, 09:14 PM
Hi.. good to see you again
۞ TPS ۞
Thu Jun 27 2019, 07:31 AM
Hello
AdiGhazi
Tue Jun 18 2019, 11:21 AM
Hlo Dear , I've to program AT89C51AC3 RT-LUM using flip but I'm getting time out error for RS232. Will you please suggest me which programmer will be supportable to program this Chip.

Downloads

Comments

3AAPC
Sun Jul 21 2019, 12:41 AM
rpels7707
Fri Jul 19 2019, 11:31 AM
ameya123
Fri Jul 19 2019, 07:36 AM
anhsieuno
Thu Jul 18 2019, 11:39 AM
zxcvbnm1234
Sat Jul 13 2019, 07:09 AM
surajghayal
Wed Jul 10 2019, 01:17 PM
figureyang
Fri Jul 05 2019, 04:25 AM
mousompal
Sat Jun 29 2019, 05:02 PM

Online

Guests: 34, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 38081
Newest member: 3AAPC
Forum Activity
3AAPC Avatar
Posted By 3AAPC
Sun Jul 21 2019, 12:51 AM
3AAPC Avatar
Posted By 3AAPC
Sun Jul 21 2019, 12:47 AM
With the GPS antenna in the outdoors, I use the ub...
ameya123 Avatar
Posted By ameya123
Fri Jul 19 2019, 07:42 AM
Hello,Please share 8051 Assembly language code for...
figureyang Avatar
Posted By figureyang
Fri Jul 05 2019, 04:37 AM
here is the source code prepared for you download ...
figureyang Avatar
Posted By figureyang
Fri Jul 05 2019, 04:30 AM
Cheap_Flash_FS(Normal Version)--Embedded FAT16/32 ...
wimac Avatar
Posted By wimac
Sat Jun 22 2019, 01:26 PM
I’ve use the AT89C51ED2 which has a similar progra...
ExperimenterUK Avatar
Posted By ExperimenterUK
Thu Jun 20 2019, 10:08 PM
baud rate is 9600 at stop bits of 2. AdiGhaziThe u...
AdiGhazi Avatar
Posted By AdiGhazi
Thu Jun 20 2019, 05:24 AM
Dear,I'm using RS232 serial port cable to use flip...
ExperimenterUK Avatar
Posted By ExperimenterUK
Tue Jun 18 2019, 10:19 PM
Okay.. I have never programmed the AT89C51AC3 or ...
AdiGhazi Avatar
Posted By AdiGhazi
Tue Jun 18 2019, 11:20 AM
Hlo Dear ,I've to program AT89C51AC3 RT-LUM using ...