Discussion in "Project Doubts" started by    LAMBO    Apr 12, 2018.
Thu Apr 12 2018, 06:51 PM
#1
hii sir,
I am working on ac motor controller .I have connected circuit as per given circuit diagram but sir instead of this
sbit led1 = p3^7;
sbit led2 = p3^6;
rest all led are glowing
and sir i don't get output on optocoupler as well
and sir innstead of 9v transformer I have used 9 volt battery as input.
plz help me out
is something wrong with program code..
Fri Apr 13 2018, 02:09 AM
#2
I assume you are doing this project.
http://www.8051projects.net/download-d238-single-phase-ac-motor-speed-controller-project-report.html

In that case it will not work if you replace the 9v transformer with a battery.
The transformer provides a timing signal.

The LEDs should still change when you press the buttons.
Have you got a serial connection to your PC ?
Mon Apr 16 2018, 06:39 AM
#3
Hi sir
i haven't connected any serial connection to pcb to pc i am controlling my speed of motor by means of switch sw2 and sw3
sir isn't any problem if i control my speed of motor by means of switch sw2 and sw3 ?? and sir how a transformer can provide a timing signal ?

Mon Apr 16 2018, 08:49 PM
#4
On the diagram, a diode feeds a rectified sine wave to R1.
The circuit feeds a signal to P3.2 (INT 0) at the low point.
This pulse is needed to time the output on P0.0

Using a battery you will not get an output on P0.0
but you should still see the LEDs on port 2 change
as you press buttons SW2 and SW3

>Sir isn't any problem if i control my speed of motor
>by means of switch sw2 and sw3 ??
No problem, I ask because a serial link can be useful for testing.
It is easy to add with a USB/Serial adapter.

The 240 volt circuit seems close to the low voltage side.
240 volts can kill.

Move the 240 volt circuit and MOC3011 to a separate board.


[ Edited Mon Apr 16 2018, 10:25 PM ]
Fri Apr 27 2018, 05:33 PM
#5
Hi sir

       I have connected circuit as per given circuit diagram every thing is working fine and mine optocoupler is showing ouptut as well but sir mine fan is not showing any response even though i am pressing increment and decrement switch and i am using exhaust fan and in snubber circuit i have kept  R value as 390 ohm and C value is 103/1kw and sir i have also connected 200 watt bulb in place of exhaust fan but its same it also not showing any response
Fri Apr 27 2018, 08:03 PM
#6
Using a light bulb is a good idea.

Disconnect the mains side of things while testing.

Fit an LED in place of the control side of the MOC3011.
That is.
Disconnect the MOC3011 and put an LED between the 220ohm
resistor and the 8051 pin 39. (port 0.0)


It should turn on and off and vary in response to to buttons.

Do the indicator LEDs change as expected ?




[ Edited Fri Apr 27 2018, 08:08 PM ]
Sat Apr 28 2018, 08:00 AM
#7
Hi sir
as u told i have connected led between 220 ohm resistor and pin 39 and the led turn on and off and vary in response to buttons as expected
Sat Apr 28 2018, 08:33 PM
#8
If the LED is turning on and off and varying, then the fault is
on the mains side.
Does the light turn on and off when connected to the micro ?
If it is always on, you have a faulty triac, or your wiring
is wrong.
Mon Apr 30 2018, 10:33 AM
#9
Since we are in india working output is 240VAC and 50HZ. I tried moc2021 with BT136 as following connections. Fan is getting on without any firing of triac. Also the 460 Ohms resistance heats up.

Mon Apr 30 2018, 06:48 PM
#10
You say you used a MOC2021, I can't find a data sheet , is it a MOC2021 ?

Okay.. so current is flowing to the motor ,we need to find out how.
First change the motor to a light bulb, say 100Watts. it will give a better idea of how
much current is flowing.

Is it full brightness ?
Next remove the opto-isolator.
Any change ?
Remove 360 ohm resistor and 0.05Uf cap
Any change ?
Remove BT136.
Report back.

Get Social

Information

Powered by e107 Forum System

Conversation

ExperimenterUK
Sat Sep 29 2018, 06:28 PM
Please post questions in the forum.
Sat Sep 29 2018, 11:26 AM
Ashfaq Ch
hi i have some AT89C51RC microcontrollers already programed. some one help us to how to download from AT89C51RC and after study and edit all corractions reload to AT89C51RC controller
shshistiem
Wed Sep 12 2018, 10:58 PM
hii!! some1 please let me know how i ll get rfid code to 8051 by WEIGAND mode
DrNossberg
Tue Sep 11 2018, 08:09 PM
is there anyone here?
Mon Aug 27 2018, 07:30 AM
bun
Hello everyone!
Sat Jul 21 2018, 06:21 AM
Dibakar Bhanja Chowdhury
By using a 555 timer how can I expand the range of the mobile phone jammer? Please reply me asap
Sun May 20 2018, 10:01 AM
justinb
how to write and execute a program that read the keypad button and display the number on 7 segment on intel8051 at89s52 in assembly language?
Thu May 17 2018, 06:36 AM
HAMZA TAJ
sir iwant to ask about controller of three phase supply by using back to back thyristor instead of triac....will u give me some guideline?
Sat Apr 28 2018, 12:54 PM
ashutosh jain
IR Remote Switch using TV remote (RC5 Protocol) is not working properly. opp1 & opp2 is in problem.plz help
ExperimenterUK
Fri Apr 27 2018, 08:09 PM
@kaiserslautern Post in forum

Downloads

Comments

PCBindex
Fri Sep 14 2018, 02:45 AM
sirkit
Thu Sep 13 2018, 04:46 AM
shshistiem
Wed Sep 12 2018, 10:36 PM
DrNossberg
Tue Sep 11 2018, 03:25 PM
ranjanvh
Thu Sep 06 2018, 02:28 PM
rbbhamre
Tue Sep 04 2018, 06:15 PM
Tressie
Sun Sep 02 2018, 02:20 PM
Sudhansudeep
Fri Aug 31 2018, 08:26 AM

Online

Guests: 46, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 38006
Newest member: PCBindex
Forum Activity
ExperimenterUK Avatar
Posted By ExperimenterUK
Thu Sep 13 2018, 08:39 PM
First of all, by reading your reply, I abandoned m...
DrNossberg Avatar
Posted By DrNossberg
Thu Sep 13 2018, 03:49 PM
Hi, thanks you for your reply ^^ First of all, by ...
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Sep 12 2018, 12:12 AM
HiThere are several issues here.The original 8051 ...
DrNossberg Avatar
Posted By DrNossberg
Tue Sep 11 2018, 08:08 PM
Hello everybody!First of all let me explain some s...
ExperimenterUK Avatar
Posted By ExperimenterUK
Fri Sep 07 2018, 05:08 AM
The compiler thinks the micro doesn't have enough...
Sudhansudeep Avatar
Posted By Sudhansudeep
Fri Sep 07 2018, 02:59 AM
this is the build output message
Sudhansudeep Avatar
Posted By Sudhansudeep
Fri Sep 07 2018, 01:38 AM
Change the mobile number as [number removed] in t...
ExperimenterUK Avatar
Posted By ExperimenterUK
Thu Sep 06 2018, 08:56 PM
I don't know what the problem is, I get no errors....
Sudhansudeep Avatar
Posted By Sudhansudeep
Thu Sep 06 2018, 01:12 PM
the code is Attachment ...
Sudhansudeep Avatar
Posted By Sudhansudeep
Thu Sep 06 2018, 12:48 PM
the code is same as u sent me for 16 chars