Discussion in "Project Addition or Changes" started by    jigneshdoshi    Jun 13, 2017.
Tue Jun 13 2017, 04:10 AM
#1
Hello All,

I am communicate AT24C1024 EEPROM with MSP430F6659 Microcontroller.

If i try to write 1 in LSB of my data then it may be microcontroller hang or it will rotate in one loop and when i write 0 then it can work proper.

But when i use MSP430F149 Microcontroller and program & EEPROM are same then it can work properly.

So what is problem occur?
Tue Jun 13 2017, 05:39 PM
#2
Hi
Really we need more information about what you are doing.
Can you post examples of code that works
and code that does not work.
Wed Jun 14 2017, 06:10 AM
#3
Please find attachment for CODE.

in this code in "write_i2c(0x02);" routine if i pass 0x01 then Microcontroller Hang and if i pass 0x02 then it can work proper.

That means if i pass 0 as LSB than it is work proper.
Tue Jul 04 2017, 04:32 AM
#4
Did you miss the attachment? I think I2C implementation might be an issue.

Get Social

Information

Powered by e107 Forum System

Conversation

Wed May 12 2021, 04:47 AM
Jenna
This paragraph will help the internet people for creating new weblog or even a weblog from start to end. Credit Report Online https://creditscoresws.com
Wed May 12 2021, 03:37 AM
Tanja
This article is actually a nice one it assists new the web people, who are wishing in favor of blogging. credit report https://creditreportsww.com

Downloads

Comments

Mirza123
Thu Jun 25 2020, 03:46 PM
eunicelove124
Mon Jun 22 2020, 03:03 PM
cerouno
Tue Jun 16 2020, 05:10 PM
Marce
Sat Jun 13 2020, 09:43 PM
Davidthils
Thu May 21 2020, 12:44 PM
Jakeror
Thu May 21 2020, 01:28 AM
motorCar
Wed May 20 2020, 07:05 PM
Vordrync
Wed May 20 2020, 11:52 AM

Online

Guests: 108, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 38215
Newest member: Mirza123