Discussion in "Project Doubts" started by    LAMBO    Apr 12, 2018.
Thu Apr 12 2018, 06:51 PM
#1
hii sir,
I am working on ac motor controller .I have connected circuit as per given circuit diagram but sir instead of this
sbit led1 = p3^7;
sbit led2 = p3^6;
rest all led are glowing
and sir i don't get output on optocoupler as well
and sir innstead of 9v transformer I have used 9 volt battery as input.
plz help me out
is something wrong with program code..
Fri Apr 13 2018, 02:09 AM
#2
I assume you are doing this project.
http://www.8051projects.net/download-d238-single-phase-ac-motor-speed-controller-project-report.html

In that case it will not work if you replace the 9v transformer with a battery.
The transformer provides a timing signal.

The LEDs should still change when you press the buttons.
Have you got a serial connection to your PC ?
Mon Apr 16 2018, 06:39 AM
#3
Hi sir
i haven't connected any serial connection to pcb to pc i am controlling my speed of motor by means of switch sw2 and sw3
sir isn't any problem if i control my speed of motor by means of switch sw2 and sw3 ?? and sir how a transformer can provide a timing signal ?

Mon Apr 16 2018, 08:49 PM
#4
On the diagram, a diode feeds a rectified sine wave to R1.
The circuit feeds a signal to P3.2 (INT 0) at the low point.
This pulse is needed to time the output on P0.0

Using a battery you will not get an output on P0.0
but you should still see the LEDs on port 2 change
as you press buttons SW2 and SW3

>Sir isn't any problem if i control my speed of motor
>by means of switch sw2 and sw3 ??
No problem, I ask because a serial link can be useful for testing.
It is easy to add with a USB/Serial adapter.

The 240 volt circuit seems close to the low voltage side.
240 volts can kill.

Move the 240 volt circuit and MOC3011 to a separate board.


[ Edited Mon Apr 16 2018, 10:25 PM ]
Fri Apr 27 2018, 05:33 PM
#5
Hi sir

       I have connected circuit as per given circuit diagram every thing is working fine and mine optocoupler is showing ouptut as well but sir mine fan is not showing any response even though i am pressing increment and decrement switch and i am using exhaust fan and in snubber circuit i have kept  R value as 390 ohm and C value is 103/1kw and sir i have also connected 200 watt bulb in place of exhaust fan but its same it also not showing any response
Fri Apr 27 2018, 08:03 PM
#6
Using a light bulb is a good idea.

Disconnect the mains side of things while testing.

Fit an LED in place of the control side of the MOC3011.
That is.
Disconnect the MOC3011 and put an LED between the 220ohm
resistor and the 8051 pin 39. (port 0.0)


It should turn on and off and vary in response to to buttons.

Do the indicator LEDs change as expected ?




[ Edited Fri Apr 27 2018, 08:08 PM ]
Sat Apr 28 2018, 08:00 AM
#7
Hi sir
as u told i have connected led between 220 ohm resistor and pin 39 and the led turn on and off and vary in response to buttons as expected
Sat Apr 28 2018, 08:33 PM
#8
If the LED is turning on and off and varying, then the fault is
on the mains side.
Does the light turn on and off when connected to the micro ?
If it is always on, you have a faulty triac, or your wiring
is wrong.
Mon Apr 30 2018, 10:33 AM
#9
Since we are in india working output is 240VAC and 50HZ. I tried moc2021 with BT136 as following connections. Fan is getting on without any firing of triac. Also the 460 Ohms resistance heats up.

Mon Apr 30 2018, 06:48 PM
#10
You say you used a MOC2021, I can't find a data sheet , is it a MOC2021 ?

Okay.. so current is flowing to the motor ,we need to find out how.
First change the motor to a light bulb, say 100Watts. it will give a better idea of how
much current is flowing.

Is it full brightness ?
Next remove the opto-isolator.
Any change ?
Remove 360 ohm resistor and 0.05Uf cap
Any change ?
Remove BT136.
Report back.

Get Social

Information

Powered by e107 Forum System

Conversation

Thu Jun 11 2020, 06:27 AM
anudee
sir could please send the code for I2C and wifi interfacing with 8051
scena
Tue May 19 2020, 10:29 PM
Does anyone have microcontroller programming software for STC15F104W (core 8051, 4 k, 128 byte, 6 I/O pin, UART ... DIL8), that works?
Sat May 02 2020, 07:38 PM
Tamu Gurung
Hi I am looking for a assembly language program for a digital decimal counter. Time counts max limit of 2 mins starting from 2.00 mins and ending at 0.00. time is to be displayed on 4 7-segment LED displays. Edsim51 simulator to be used. Thanks
Wed Mar 25 2020, 01:39 PM
Tajammul
Sir kindly send the code file i2c for 8051
ExperimenterUK
Fri Mar 13 2020, 10:36 PM
@ Rohitnani,ABEBE..which project ?
Fri Mar 13 2020, 12:55 PM
ABEBE
how can get hadwere of this project
Rohitnani
Sat Mar 07 2020, 05:11 PM
Sir, Could you please send me the zip file input password....
Wed Feb 26 2020, 04:58 PM
Peter Parker
Is it possible to send multiple messages using only 1 GSM module?
Sat Feb 01 2020, 10:12 AM
Pearl Olin
Hello,
Wed Jan 22 2020, 06:16 PM
MINU CHAUDHARY
I m getting errors while simulation process during interfacing socket output and lcd... Can i get the report of ur project which is same as us.

Downloads

Comments

Mirza123
Thu Jun 25 2020, 03:46 PM
eunicelove124
Mon Jun 22 2020, 03:03 PM
cerouno
Tue Jun 16 2020, 05:10 PM
Marce
Sat Jun 13 2020, 09:43 PM
Davidthils
Thu May 21 2020, 12:44 PM
Jakeror
Thu May 21 2020, 01:28 AM
motorCar
Wed May 20 2020, 07:05 PM
Vordrync
Wed May 20 2020, 11:52 AM

Online

Guests: 82, Members: 0 ...

most ever online: 182184
(Members: , Guests: 182184) on 06 Aug 2010: 05:37 AM

Members: 38215
Newest member: Mirza123
Forum Activity
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Jul 01 2020, 11:07 PM
PS: I am a new learner thats why my question may s...
Mirza123 Avatar
Posted By Mirza123
Wed Jul 01 2020, 02:05 PM
Thanks for the assistance. I have read the data sh...
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Jul 01 2020, 10:12 AM
See section 15 (Ports) of the data sheet. ...
wimac Avatar
Posted By wimac
Tue Jun 30 2020, 10:05 AM
How did you know that it is not 8051. Mirza123It i...
Mirza123 Avatar
Posted By Mirza123
Tue Jun 30 2020, 08:39 AM
It seems ports on the AT89LP2052 is not like on th...
ExperimenterUK Avatar
Posted By ExperimenterUK
Tue Jun 30 2020, 08:34 AM
It seems ports on the AT89LP2052 are not like on t...
Mirza123 Avatar
Posted By Mirza123
Thu Jun 25 2020, 04:07 PM
Hello!i am trying to use AT89LP2052 ( AT89LP2052 h...
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Jun 17 2020, 09:42 PM
It is about capacitor? i should put it between Vcc...
cerouno Avatar
Posted By cerouno
Wed Jun 17 2020, 10:37 AM
Take another look at the power supply to the LCD.A...
ExperimenterUK Avatar
Posted By ExperimenterUK
Wed Jun 17 2020, 02:01 AM
Take another look at the power supply to the LCD.A...